Verificatore della forza della chiave DKIM

Verifica il selettore DKIM, la lunghezza della chiave, l'algoritmo, la funzione hash e i flag, e ottieni un punteggio chiaro relativo al livello di sicurezza con raccomandazioni specifiche per l'aggiornamento, al fine di prevenire errori di firma.
Verifica della lunghezza della chiave e dell'algoritmo SHA-1 e rilevamento delle chiavi deboli Rileva automaticamente i selettori più comuni 100% gratuito
Selettori comuni:
Inserisci un dominio e (facoltativamente) un selettore DKIM. Lascia il campo del selettore vuoto – oppure, se non viene trovato – e provvederemo a rilevare automaticamente quelli più comuni.

Come funziona lo strumento di verifica della sicurezza delle chiavi DKIM

Inserisci il tuo dominio e il selettore DKIM: lo strumento eseguirà una ricerca DNS in tempo reale, estrarrà la tua chiave pubblica ed effettuerà un’analisi crittografica completa.

1
Inserisci il dominio e il selettore. Indica il tuo dominio principale e il selettore DKIM utilizzato dal tuo server di posta. Tra i selettori più comuni figurano default, google, s1, e selector1 - oppure lasciare il campo vuoto per il rilevamento automatico.
2
Vengono eseguiti i controlli di sicurezza. Analizziamo la lunghezza della chiave, il tipo di algoritmo, la funzione hash, il flag di servizio e il flag di test, quindi assegniamo alla tua chiave un punteggio da 0 a 100.
3
Ricevi consigli prioritari. Scopri esattamente quali controlli non hanno superato la verifica e perché, con procedure correttive specifiche ordinate in base al rischio per risolvere i problemi legati alle chiavi deboli e agli algoritmi obsoleti.

Cosa analizza il Checker

Ogni controllo riguarda un aspetto crittografico o operativo della chiave di firma DKIM dell'utente, che può essere ricavato dal DNS pubblico.

Lunghezza chiave
L'RSA-1024 è ormai obsoleto e, con le moderne risorse di calcolo, è possibile scomporlo in fattori. La lunghezza minima consigliata è di 2048 bit per l'RSA; le chiavi a curva ellittica Ed25519 rappresentano la migliore pratica attuale.
Guida alla rotazione delle chiavi DKIM →
Algoritmo di hash
SHA-1 è ormai superato dal punto di vista crittografico: esistono collisioni pratiche e molti destinatari stanno iniziando a rifiutare le e-mail firmate con SHA-1. SHA-256 (h=sha256) è obbligatorio.
Che cos’è il DKIM? →
Bandiere e rotazione
Segnaliamo la mancanza di un s=email codice di servizio e il t=y Flag di prova. Il DNS non è in grado di rivelare la durata della chiave, pertanto la rotazione viene indicata a titolo di promemoria e non come punteggio: si consiglia di effettuare la rotazione all'incirca ogni 6 mesi.
Come ruotare le chiavi DKIM →

Problemi comuni relativi alla sicurezza delle chiavi DKIM

Questi sono i problemi più gravi individuati dallo strumento di verifica e il loro impatto sulla sicurezza delle tue e-mail.

Critico
Chiave RSA-1024 in uso
Le chiavi RSA a 1024 bit possono essere scomposte in fattori utilizzando risorse di calcolo nel cloud: il NIST ha dichiarato obsoleta la RSA-1024 nel 2013 e Gmail ha iniziato a segnalare (e a rifiutare) le firme DKIM a 1024 bit.
Genera una nuova chiave RSA a 2048 bit (o Ed25519) tramite il tuo ESP o server di posta, pubblica il nuovo record, attendi 48 ore, quindi disattiva la vecchia chiave.
Crea un nuovo record DKIM →
Critico
Algoritmo di hash SHA-1
SHA-1 è ormai considerato crittograficamente compromesso: esistono attacchi di collisione pratici di dominio pubblico e la RFC 8301 ne sconsiglia esplicitamente l'uso per DKIM. Qualsiasi record che utilizzi h=sha1 dovrebbe essere considerato non sicuro.
Aggiorna il tuo record per utilizzare h=sha256 e rigenerare la coppia di chiavi tramite il proprio provider di posta elettronica o ESP.
Controlla il tuo record DKIM →
Attenzione
Modalità di test attiva (t=y)
Il t=y Questo flag indica ai destinatari che il tuo dominio sta effettuando dei test su DKIM e di trattare gli errori con tolleranza. Se lasciato attivo in ambiente di produzione, compromette la protezione che DKIM è destinato a garantire.
Rimuovi t=y dal record DKIM una volta verificato che la firma funzioni correttamente.
Attenzione
Nessun indicatore del tipo di servizio
Senza un s=email È importante sottolineare che questa chiave non è limitata alla sola firma delle e-mail: in teoria può essere utilizzata anche per altri servizi, ampliando così la superficie di attacco.
Aggiungi s=email al tuo record TXT DKIM per limitare l'uso della chiave alla firma delle e-mail (best practice RFC 6376).

Confronto tra algoritmi di firma DKIM

Non tutte le configurazioni DKIM offrono lo stesso livello di sicurezza. Ecco un confronto tra i tipi di chiave più diffusi in termini di sicurezza, prestazioni e diffusione.

AlgoritmoDimensione della chiaveStato di sicurezzaPrestazioniRaccomandazione
RSA-10241024 bitObsoletoFirma rapidaEsegui subito l'aggiornamento
RSA-20482048 bitAccettabileModeratoMinimo consigliato
RSA-40964096 bitForteFirma più lentaAdatto per impieghi che richiedono un elevato livello di sicurezza
Ed25519256 bit (EC)Migliori praticheIl più veloceMigliori pratiche moderne (RFC 8463)

Domande frequenti

Che cos’è un selettore DKIM e come faccio a trovare il mio?
Un selettore DKIM è un'etichetta breve che identifica quale chiave pubblica utilizzare durante la verifica di una firma DKIM. Appare nel s= tag del DKIM-Signature intestazione di qualsiasi email in uscita. Per trovare la tua, apri le intestazioni in formato grezzo di un’email inviata dal tuo dominio e cerca s=. Tra i selettori più comuni figurano default, google, s1, selector1 e k1. Lascia il campo del selettore vuoto e provvederemo a rilevare automaticamente quelli più comuni.
Con quale frequenza dovrei aggiornare le mie chiavi DKIM?
La pratica consigliata consiste nel ruotare le chiavi DKIM ogni 3-6 mesi: generare una nuova coppia di chiavi, pubblicare la nuova chiave pubblica con un nuovo selettore, attendere 48 ore per la propagazione del DNS, impostare il server di posta in modo che utilizzi la nuova chiave privata per la firma, quindi rimuovere il record del vecchio selettore. Si noti che il DNS non è in grado di rivelare quando una chiave è stata creata, pertanto questo strumento non può indicare l’età di una chiave: è possibile monitorare la rotazione tramite gli strumenti di analisi DKIM di PowerDMARC.
Perché l'RSA-1024 è considerato pericoloso?
L'RSA-1024 può essere scomposto in fattori utilizzando cluster di calcolo di livello accademico ed è sempre più alla portata di aggressori dotati di risorse adeguate. Il NIST ha deprecato l'RSA a 1024 bit nel 2013 e Google ha iniziato ad avvisare i mittenti che utilizzavano chiavi DKIM a 1024 bit nel 2023. Se un malintenzionato riesce a scomporre in fattori la tua chiave privata a 1024 bit, potrà falsificare le firme DKIM per qualsiasi e-mail che sembri provenire dal tuo dominio. Utilizza almeno RSA-2048 o Ed25519.
Che cos’è Ed25519 e dovrei passare a questo standard?
Ed25519 è un algoritmo di firma a curva ellittica definito nella RFC 8463 per DKIM. Una chiave Ed25519 a 256 bit offre un livello di sicurezza paragonabile a quello di una chiave RSA da circa 3000 bit, garantisce una maggiore velocità di firma e verifica e mantiene i record DNS compatti. La considerazione principale riguarda la compatibilità: non tutti i server di posta supportano ancora la RFC 8463. Se la vostra infrastruttura lo supporta, Ed25519 rappresenta la migliore pratica attuale; molte organizzazioni utilizzano in parallelo selettori RSA-2048 ed Ed25519.
Cosa significa il punteggio relativo alla sicurezza di una chiave DKIM?
Il punteggio da 0 a 100 riflette la robustezza crittografica della tua chiave DKIM, per quanto rilevabile tramite il DNS: lunghezza della chiave, algoritmo, funzione hash, il flag s= del servizio e-mail, il flag t= di test e il TTL. Le fasce sono: 0-20 Critico, 21-40 Debole, 41-65 Buono, 66-85 Forte, 86-100 Eccellente. Si tratta di un indicatore rapido: controlla sempre i singoli controlli e le raccomandazioni per correzioni specifiche.

Automatizza il monitoraggio DKIM su tutti i tuoi domini

PowerDMARC monitora lo stato di integrità della firma DKIM, la sicurezza delle chiavi e lo stato dei selettori in un'unica dashboard, con avvisi che vengono inviati non appena una firma risulta non valida o una chiave diventa meno sicura.