DNS, kurz für „Domain Name System“, ist ein Dienst, der Domainnamen in IP-Adressen umwandelt. Auf diese Weise weiß Ihr Browser, wie er die gesuchte Website finden kann, wenn Sie eine URL eingeben.
Um zu verstehen, wie das DNS im Internet funktioniert, ist es hilfreich, zwischen zwei grundlegenden Konzepten zu unterscheiden: DNS-Abfragetypen (wie Clients und Resolver kommunizieren) und DNS-Serverrollen (wie verschiedene Server Einträge speichern, Anfragen weiterleiten oder Daten zwischenspeichern).
Die gängigsten DNS-Abfragetypen erklärt
Wenn Ihr Gerät oder eine Anwendung eine Adresse nachschlägt, kommen bei der DNS-Auflösung bestimmte Abfragemethoden zum Einsatz:
1. Rekursive DNS-Abfrage
Bei einer rekursiven Abfrage fordert der Client (z. B. der Stub-Resolver Ihres Betriebssystems) einen rekursiven Resolver auf, den Domainnamen vollständig aufzulösen. Der Resolver übernimmt die gesamte Arbeit, die Antwort zu finden, und fragt andere Server im Internet ab, bis er die endgültige IP-Adresse ermittelt hat und diese an Ihr Gerät zurückgibt.
2. Nicht-rekursive DNS-Abfrage
Gemäß RFC 9499 wird eine nicht-rekursive Abfrage als eine Abfrage definiert, bei der das „Recursion Desired“ (RD)-Bit auf 0 gesetzt ist. Im nicht-rekursiven Modus verfolgt der abgefragte Nameserver die Anfrage nicht weiter im Auftrag des Clients; gemäß RFC 1034, Abschnitt 4.3.1, gibt er sofort eine Antwort zurück (sofern er über autoritative Daten verfügt oder den Eintrag im Cache hat), einen Fehler oder eine Weiterleitung an Nameserver, die in der Hierarchie untergeordnet sind.
Iterative Abfragen sind selbst nicht-rekursive Abfragen. Bei der iterativen Auflösung sendet der rekursive Resolver eine Abfolge nicht-rekursiver (RD=0) Abfragen entlang der DNS-Hierarchie, wobei er den Verweisen von Root-Servern zu TLD-Servern folgt, bis er einen autoritativen Nameserver für die Zieldomäne erreicht.
Gängige DNS-Server-Typen erklärt
1. Primärer DNS-Server
Der primäre DNS-Server (Master-Server) ist der autoritative Nameserver, auf dem die ursprüngliche, bearbeitbare Masterkopie der Zonendatei einer Domain gespeichert ist. Alle Änderungen an den DNS-Einträgen Ihrer Domain – wie beispielsweise die Aktualisierung einer IP-Adresse oder das Hinzufügen eines Authentifizierungseintrags – werden direkt auf dem primären Server vorgenommen.
2. Sekundärer DNS-Server
Ein sekundärer DNS-Server (Slave-Server) ist ein autoritativer Nameserver, der über einen automatisierten Vorgang, der als Zonentransfer bezeichnet wird (AXFR gemäß RFC 5936 oder inkrementeller IXFR gemäß RFC 1995, bekannt gegeben über RFC 1996), eine identische, schreibgeschützte Kopie der Zonendatei vom primären Server erhält.
Entgegen einer weit verbreiteten Fehlannahme ist ein sekundärer DNS-Server nicht ein Standby-Backup, das nur dann aktiviert wird, wenn der Primärserver ausfällt. Alle in der Domain aufgeführten Nameserver NS Die Einträge sind gleichzeitig aktiv. Resolver bevorzugen in der Regel Nameserver, die in der Vergangenheit schneller geantwortet haben (basierend auf Statistiken zur gemessenen Round-Trip-Zeit, wie in RFC 1034 Abschnitt 5.3.3 und RFC 2182 beschrieben). Sekundärserver sorgen für eine aktive Lastverteilung und geografische Redundanz und können auf der Infrastruktur von Drittanbietern, in unabhängigen Cloud-Netzwerken oder auf dedizierten Nameservern gehostet werden.
3. Tertiärer DNS-Server
In der Architektur autoritativer DNS-Server gibt es kein offizielles Konzept, das als „tertiärer DNS-Server“ bezeichnet wird. Autoritative Konfigurationen basieren ausschließlich auf primären und sekundären Beziehungen (wobei Domains häufig mehrere sekundäre Server nutzen, um zusätzliche Redundanz zu gewährleisten).
Der Begriff „tertiärer DNS“ taucht in der Regel nur in den Einstellungen des Betriebssystems auf der Client-Seite oder in den Netzwerkadapter-Einstellungen eines Routers auf. In diesen Einstellungen finden Sie möglicherweise Felder für „bevorzugte“, „alternative“ und gelegentlich auch „tertiäre“ DNS-Server. Diese Felder enthalten eine Liste externer rekursiver Resolver, auf die Ihr lokales Gerät in der Regel nacheinander zurückgreift, wenn der erste Resolver nicht antwortet.
4. Weiterleitender DNS-Resolver
Ein weiterleitender DNS-Server (oder „Forwarder“) ist ein Resolver, der so konfiguriert ist, dass er eingehende Abfragen an einen anderen, festgelegten Upstream-Resolver weiterleitet, anstatt den vollständigen rekursiven Auflösungsprozess selbst durchzuführen (RFC 9499).
DNS-Weiterleitung wird häufig in Unternehmens- und privaten Netzwerken eingesetzt. Sie ermöglicht es Administratoren, interne Domain-Abfragen an lokale Server weiterzuleiten, während alle externen Internet-Abfragen über ein zentrales, gesichertes Gateway weitergeleitet werden. Diese Konfiguration zentralisiert den ausgehenden DNS-Verkehr, verbessert die Netzwerkeffizienz und vereinfacht die Durchsetzung von Sicherheitsrichtlinien und die Inhaltsfilterung.
5. Reiner Cache-DNS-Server
Ein reiner Caching-DNS-Server ist ein rekursiver Resolver, der keine eigenen autoritativen Zonen hostet. Sein einziger Zweck besteht darin, rekursive Abfragen für Clients im lokalen Netzwerk zu verarbeiten, die Antworten entsprechend der Time-to-Live-Zeit (TTL) des Eintrags im lokalen Speicher-Cache zu speichern und zukünftige identische Abfragen sofort aus dem Cache zu beantworten.
Diese Art von DNS-Server beschleunigt die Browsing-Leistung in lokalen Netzwerken, indem sie wiederholte Abfragen über das Internet überflüssig macht. Zwar lassen sich netzwerkweite Domain-Filter (wie DNS Response Policy Zones oder Blocklisten) auf Caching-Resolvern implementieren, um bösartige Domains zu blockieren, doch handelt es sich bei der Filterung eher um eine Verwaltungsfunktion als um eine Funktion, die ausschließlich Caching-Servern vorbehalten ist.
Allgemeine DNS-Eintragstypen erklärt
Einige der gängigsten DNS-Typen sind:
1. A Aufzeichnungen
A-Einträge (Adress-Einträge) werden verwendet, um einen Domainnamen oder Hostnamen einer 32-Bit-IPv4-Adresse zuzuordnen (RFC 1035). Für moderne IPv6-Netzwerke ist der entsprechende Eintrag der AAAA-Eintrag, der einen Hostnamen einer 128-Bit-IPv6-Adresse zuordnet (RFC 3596). Diese Einträge sind grundlegend für die Verbindung von Client-Geräten mit Webservern, Mailservern und API-Endpunkten.
2. CNAME-Einträge
CNAME-Einträge (Canonical Name-Einträge) machen einen Domainnamen zu einem Alias eines anderen kanonischen Domainnamens (RFC 1034). Dadurch können mehrere Hostnamen (wie beispielsweise www.example.com oder blog.example.com) auf einen einzigen kanonischen Namen (wie example.com) verweisen, sodass sichergestellt ist, dass alle Aliase automatisch aktualisiert werden, falls sich die IP-Adresse des kanonischen Ziels ändert.
Wichtig ist, dass gemäß RFC 2181, Abschnitt 10.1, ein CNAME-Eintrag kann nicht zusammen mit anderen Datensätzen als DNSSEC-Datensätzen (wie RRSIG und NSEC) vorkommen für denselben Hostnamen. Da die Root oder der Zonen-Apex einer Domain (z. B. example.com) schreibt vor, dass SOA und NS Bei DNS-Einträgen darf ein CNAME nicht an der obersten Ebene der Zone platziert werden.
3. MX-Einträge
MX-Einträge (Mail-Exchanger-Einträge) leiten eingehende E-Mail-Nachrichten an die Mailserver weiter, die für die Bearbeitung der E-Mails einer Domain zuständig sind. Jeder MX-Eintrag gibt den Hostnamen eines Mailservers und einen Präferenzwert (Priorität) an. Absendende Mailserver versuchen zunächst, die E-Mail an den Server mit der niedrigsten Präferenznummer zuzustellen, und greifen auf Server mit höheren Nummern zurück, falls dieser Server nicht verfügbar ist.
Gemäß RFC 2181, Abschnitt 10.3, muss der in einem MX-Eintrag angegebene Hostname direkt auf einen Adresseintrag verweisen (A oder AAAA) verweisen und darf niemals auf einen CNAME-Alias.
DNS ist unglaublich wichtig, denn nur so können wir von unseren Computern oder Telefonen aus auf Websites und andere Online-Dienste zugreifen, ohne uns jedes Mal alle IP-Adressen merken zu müssen, wenn wir auf sie zugreifen wollen (was schwierig sein kann, wenn Sie mehrere Geräte haben). Wenn jedoch etwas mit dem DNS schief läuft, kann dies zu Problemen beim Zugriff auf diese Websites führen - oder sogar noch schlimmer!